Upgrade Oracle Enterprise Linux (OEL) 6 to OEL 7

In this article, we will discuss how can upgrade Oracle Linux from 6 to 7 on VM. We are planning to upgrade Oracle Database 12.1.0.2 to 19c. Database server’s OS is OEL 6.8 but oracle database 19c is not certified on OEL 6.8. So need to upgrade OS from version 6.8 to 7.6.

Current Version:

[oracle@proddb ~]$ uname -a
Linux proddb.localdomain 4.1.12-37.4.1.el6uek.x86_64 #2 SMP Tue May 17 07:23:38 PDT 2016 x86_64 x86_64 x86_64 GNU/Linux

[oracle@proddb ~]$ lsb_release -a
LSB Version:    :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: OracleServer
Description:    Oracle Linux Server release 6.8
Release:        6.8
Codename:       n/a

[oracle@proddb ~]$ cat /proc/version
Linux version 4.1.12-37.4.1.el6uek.x86_64 (mockbuild@x86-ol6-builder-05) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-11) (GCC) ) #2 SMP Tue May 17 07:23:38 PDT 2016

[oracle@proddb ~]$ cat /etc/*-release
LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Oracle Linux Server release 6.8
NAME="Oracle Linux Server"
VERSION="6.8"
ID="ol"
VERSION_ID="6.8"
PRETTY_NAME="Oracle Linux Server 6.8"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:oracle:linux:6:8:server"
HOME_URL="https://linux.oracle.com/"
BUG_REPORT_URL="https://bugzilla.oracle.com/"

ORACLE_BUGZILLA_PRODUCT="Oracle Linux 6"
ORACLE_BUGZILLA_PRODUCT_VERSION=6.8
ORACLE_SUPPORT_PRODUCT="Oracle Linux"
ORACLE_SUPPORT_PRODUCT_VERSION=6.8
Red Hat Enterprise Linux Server release 6.8 (Santiago)
Oracle Linux Server release 6.8

Note::: Make sure you have taken backup of required filesystems.

Download OEL targeted version from oracle site: Download

Update Latest OEL 6 Version:

[root@proddb ~]# yum update -y
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Update Process
public_ol6_UEKR4                                                                                                       | 2.5 kB     00:00
public_ol6_latest                                                                                                      | 2.7 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package GConf2.x86_64 0:2.28.0-6.el6 will be updated
---> Package GConf2.x86_64 0:2.28.0-7.el6 will be an update
---> Package GConf2-gtk.x86_64 0:2.28.0-6.el6 will be updated
---> Package GConf2-gtk.x86_64 0:2.28.0-7.el6 will be an update


... ... ...

Transaction Summary
==============================================================================================================================================
Install       9 Package(s)
Upgrade     401 Package(s)

Total download size: 579 M
Downloading Packages:
(1/410): GConf2-2.28.0-7.el6.x86_64.rpm                                                                                | 962 kB     00:01

Installed:
  kernel.x86_64 0:2.6.32-754.33.1.el6                                 kernel-uek.x86_64 0:4.1.12-124.42.3.el6uek
  kernel-uek-firmware.noarch 0:4.1.12-124.42.3.el6uek                 linux-firmware.noarch 0:20171128-56.git17e62881.0.2.el6

Dependency Installed:
  copy-jdk-configs.noarch 0:3.3-9.el6     libkadm5.x86_64 0:1.10.3-65.el6                       oraclelinux-release-el6.noarch 0:1.0-7.el6
  python-six.noarch 0:1.9.0-2.el6         python-sss-murmur.x86_64 0:1.13.3-60.0.2.el6_10.2

Updated:
  GConf2.x86_64 0:2.28.0-7.el6                                          GConf2-gtk.x86_64 0:2.28.0-7.el6
  ImageMagick.x86_64 0:6.7.2.7-6.el6                                    NetworkManager.x86_64 1:0.8.1-113.el6
  NetworkManager-glib.x86_64 1:0.8.1-113.el6                            NetworkManager-gnome.x86_64 1:0.8.1-113.el6
  ORBit2.x86_64 0:2.14.17-7.el6                                         abrt.x86_64 0:2.0.8-44.0.1.el6
  abrt-addon-ccpp.x86_64 0:2.0.8-44.0.1.el6                             abrt-addon-kerneloops.x86_64 0:2.0.8-44.0.1.el6
  abrt-addon-python.x86_64 0:2.0.8-44.0.1.el6                           abrt-cli.x86_64 0:2.0.8-44.0.1.el6
  abrt-desktop.x86_64 0:2.0.8-44.0.1.el6                                abrt-gui.x86_64 0:2.0.8-44.0.1.el6
  abrt-libs.x86_64 0:2.0.8-44.0.1.el6                                   abrt-python.x86_64 0:2.0.8-44.0.1.el6
... ... ...
  vino.x86_64 0:2.28.1-10.el6                                           virt-what.x86_64 0:1.11-1.3.el6
  vte.x86_64 0:0.25.1-10.el6_9                                          wget.x86_64 0:1.12-10.el6
  wpa_supplicant.x86_64 1:0.7.3-9.el6_9.2                               xorg-x11-drv-ati.x86_64 0:7.6.1-4.el6
  xorg-x11-drv-ati-firmware.noarch 0:7.6.1-4.el6                        xorg-x11-drv-mach64.x86_64 0:6.9.5-1.el6
  xorg-x11-drv-mga.x86_64 0:1.6.3-12.el6                                xorg-x11-server-Xorg.x86_64 0:1.17.4-17.0.2.el6
  xorg-x11-server-common.x86_64 0:1.17.4-17.0.2.el6                     yum.noarch 0:3.2.29-81.0.1.el6
  yum-plugin-security.noarch 0:1.1.30-42.0.1.el6_10                     yum-rhn-plugin.noarch 0:0.9.1-60.2.0.3.el6_8
  yum-utils.noarch 0:1.1.30-42.0.1.el6_10

Replaced:
  bfa-firmware.noarch 0:3.2.23.0-2.el6                              ivtv-firmware.noarch 2:20080701-20.2
  iwl100-firmware.noarch 0:39.31.5.1-1.el6                          iwl1000-firmware.noarch 1:39.31.5.1-1.el6
  iwl3945-firmware.noarch 0:15.32.2.9-4.el6                         iwl4965-firmware.noarch 0:228.61.2.24-2.1.el6
  iwl5000-firmware.noarch 0:8.83.5.1_1-1.el6_1.1                    iwl5150-firmware.noarch 0:8.24.2.2-1.el6
  iwl6000-firmware.noarch 0:9.221.4.1-1.el6                         iwl6000g2a-firmware.noarch 0:17.168.5.3-1.el6
  iwl6050-firmware.noarch 0:41.28.5.1-2.el6                         libertas-usb8388-firmware.noarch 2:5.110.22.p23-3.1.el6
  netxen-firmware.noarch 0:4.0.590-0.1.el6                          ql2400-firmware.noarch 0:8.02.00-1.0.1.el6
  ql2500-firmware.noarch 0:8.02.00-1.0.1.el6

Complete!

After Upgraded Latest OLE 6 – Version Details:

[root@proddb ~]# lsb_release -a
LSB Version:    :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: OracleServer
Description:    Oracle Linux Server release 6.10
Release:        6.10
Codename:       n/a
[root@proddb ~]# cat /proc/version
Linux version 4.1.12-37.4.1.el6uek.x86_64 (mockbuild@x86-ol6-builder-05) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-11) (GCC) ) #2 SMP Tue May 17 07:23:38 PDT 2016
[root@proddb ~]# cat /etc/*-release
LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Oracle Linux Server release 6.10
NAME="Oracle Linux Server"
VERSION="6.10"
ID="ol"
VERSION_ID="6.10"
PRETTY_NAME="Oracle Linux Server 6.10"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:oracle:linux:6:10:server"
HOME_URL="https://linux.oracle.com/"
BUG_REPORT_URL="https://bugzilla.oracle.com/"

ORACLE_BUGZILLA_PRODUCT="Oracle Linux 6"
ORACLE_BUGZILLA_PRODUCT_VERSION=6.10
ORACLE_SUPPORT_PRODUCT="Oracle Linux"
ORACLE_SUPPORT_PRODUCT_VERSION=6.10
Red Hat Enterprise Linux Server release 6.10 (Santiago)
Oracle Linux Server release 6.10

Install required packages to upgrade OLE 7:

yum install redhat-upgrade-tool preupgrade-assistant preupgrade-assistant-el6toel7 preupgrade-assistant-el6toel7-data-0 preupgrade-assistant-tools preupgrade-assistant-ui openscap

Some reason packages did not found on public yum server:

[root@proddb ~]# yum install openscap redhat-upgrade-tool preupgrade-assistant  preupgrade-assistant-el6toel7 preupgrade-assistant-el6toel7-data-0 preupgrade-assistant-tools preupgrade-assistant-ui
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
No package preupgrade-assistant available.
No package preupgrade-assistant-el6toel7 available.
No package preupgrade-assistant-el6toel7-data-0 available.
No package preupgrade-assistant-tools available.
No package preupgrade-assistant-ui available.
Resolving Dependencies
--> Running transaction check
---> Package openscap.x86_64 0:1.2.13-2.0.1.el6 will be installed
---> Package redhat-upgrade-tool.noarch 1:0.8.0-4.0.1.el6 will be installed
--> Processing Dependency: preupgrade-assistant >= 2.2.0-1 for package: 1:redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch
--> Finished Dependency Resolution
Error: Package: 1:redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch (public_ol6_latest)
           Requires: preupgrade-assistant >= 2.2.0-1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Tried with –skip-broken option but till did not install all component.

[root@proddb ~]# yum install openscap redhat-upgrade-tool preupgrade-assistant  preupgrade-assistant-el6toel7 preupgrade-assistant-el6toel7-data-0 preupgrade-assistant-tools preupgrade-assistant-ui --skip-broken
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
No package preupgrade-assistant available.
No package preupgrade-assistant-el6toel7 available.
No package preupgrade-assistant-el6toel7-data-0 available.
No package preupgrade-assistant-tools available.
No package preupgrade-assistant-ui available.
Resolving Dependencies
--> Running transaction check
---> Package openscap.x86_64 0:1.2.13-2.0.1.el6 will be installed
---> Package redhat-upgrade-tool.noarch 1:0.8.0-4.0.1.el6 will be installed
--> Processing Dependency: preupgrade-assistant >= 2.2.0-1 for package: 1:redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch
--> Running transaction check
---> Package redhat-upgrade-tool.noarch 1:0.8.0-4.0.1.el6 will be installed
--> Running transaction check
---> Package openscap.x86_64 0:1.2.13-2.0.1.el6 will be installed
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    1:redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch from public_ol6_latest

Dependencies Resolved

==============================================================================================================================================
 Package                               Arch                     Version                             Repository                           Size
==============================================================================================================================================
Installing:
 openscap                              x86_64                   1.2.13-2.0.1.el6                    public_ol6_latest                   3.9 M
Skipped (dependency problems):
 redhat-upgrade-tool                   noarch                   1:0.8.0-4.0.1.el6                   public_ol6_latest                   226 k

Transaction Summary
==============================================================================================================================================
Install       1 Package(s)

Total download size: 3.9 M
Installed size: 56 M
Is this ok [y/N]: y
Downloading Packages:
openscap-1.2.13-2.0.1.el6.x86_64.rpm                                                                                   | 3.9 MB     00:01
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : openscap-1.2.13-2.0.1.el6.x86_64                                                                                           1/1
  Verifying  : openscap-1.2.13-2.0.1.el6.x86_64                                                                                           1/1

Installed:
  openscap.x86_64 0:1.2.13-2.0.1.el6

Skipped (dependency problems):
  redhat-upgrade-tool.noarch 1:0.8.0-4.0.1.el6

Complete!

Add below lines to /etc/yum.repos.d/public-yum-ol6.repo manually and run the command again:

[root@proddb ~]# vi /etc/yum.repos.d/public-yum-ol6.repo
[ol6_addons]
name=Oracle Linux $releasever Add ons ($basearch)
baseurl=http://public-yum.oracle.com/repo/OracleLinux/OL6/addons/$basearch/
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle
gpgcheck=1
enabled=1
[root@proddb ~]# yum install redhat-upgrade-tool preupgrade-assistant   preupgrade-assistant-el6toel7 preupgrade-assistant-el6toel7-data-0   preupgrade-assistant-tools preupgrade-assistant-ui openscap
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
ol6_addons                                                                                                             | 2.5 kB     00:00
ol6_addons/primary_db                                                                                                  | 169 kB     00:00
public_ol6_UEKR4                                                                                                       | 2.5 kB     00:00
public_ol6_latest                                                                                                      | 2.7 kB     00:00
No package preupgrade-assistant-el6toel7-data-0 available.
Package openscap-1.2.13-2.0.1.el6.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package preupgrade-assistant.noarch 0:2.6.0-1.0.1.el6 will be installed
--> Processing Dependency: openscap-engine-sce(x86-64) >= 1.0.8 for package: preupgrade-assistant-2.6.0-1.0.1.el6.noarch
--> Processing Dependency: openscap-utils(x86-64) >= 1.0.8 for package: preupgrade-assistant-2.6.0-1.0.1.el6.noarch
--> Processing Dependency: pykickstart for package: preupgrade-assistant-2.6.0-1.0.1.el6.noarch
---> Package preupgrade-assistant-el6toel7.noarch 0:0.7.9-3.0.1.el6 will be installed
--> Processing Dependency: preupgrade-assistant-el6toel7-data for package: preupgrade-assistant-el6toel7-0.7.9-3.0.1.el6.noarch
---> Package preupgrade-assistant-tools.noarch 0:2.6.0-1.0.1.el6 will be installed
---> Package preupgrade-assistant-ui.noarch 0:2.6.0-1.0.1.el6 will be installed
--> Processing Dependency: mod_wsgi for package: preupgrade-assistant-ui-2.6.0-1.0.1.el6.noarch
---> Package redhat-upgrade-tool.noarch 1:0.8.0-4.0.1.el6 will be installed
--> Running transaction check
---> Package mod_wsgi.x86_64 0:3.2-7.el6 will be installed
---> Package openscap-engine-sce.x86_64 0:1.2.13-2.0.1.el6 will be installed
---> Package openscap-utils.x86_64 0:1.2.13-2.0.1.el6 will be installed
--> Processing Dependency: openscap-scanner(x86-64) = 1.2.13-2.0.1.el6 for package: openscap-utils-1.2.13-2.0.1.el6.x86_64
--> Processing Dependency: rpm-build for package: openscap-utils-1.2.13-2.0.1.el6.x86_64
--> Processing Dependency: rpmdevtools for package: openscap-utils-1.2.13-2.0.1.el6.x86_64
---> Package preupgrade-assistant-el6toel7-data.noarch 0:0.20190214-1.0.1.el6 will be installed
---> Package pykickstart.noarch 0:1.74.22-1.el6 will be installed
--> Running transaction check
---> Package openscap-scanner.x86_64 0:1.2.13-2.0.1.el6 will be installed
---> Package rpm-build.x86_64 0:4.8.0-59.el6 will be installed
--> Processing Dependency: system-rpm-config for package: rpm-build-4.8.0-59.el6.x86_64
---> Package rpmdevtools.noarch 0:7.5-2.0.1.el6 will be installed
--> Processing Dependency: fakeroot for package: rpmdevtools-7.5-2.0.1.el6.noarch
--> Running transaction check
---> Package fakeroot.x86_64 0:1.12.2-22.2.el6 will be installed
--> Processing Dependency: fakeroot-libs = 1.12.2-22.2.el6 for package: fakeroot-1.12.2-22.2.el6.x86_64
---> Package redhat-rpm-config.noarch 0:9.0.3-51.0.1.el6 will be installed
--> Running transaction check
---> Package fakeroot-libs.x86_64 0:1.12.2-22.2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================
 Package                                         Arch                Version                             Repository                      Size
==============================================================================================================================================
Installing:
 preupgrade-assistant                            noarch              2.6.0-1.0.1.el6                     ol6_addons                     227 k
 preupgrade-assistant-el6toel7                   noarch              0.7.9-3.0.1.el6                     ol6_addons                     396 k
 preupgrade-assistant-tools                      noarch              2.6.0-1.0.1.el6                     ol6_addons                      54 k
 preupgrade-assistant-ui                         noarch              2.6.0-1.0.1.el6                     ol6_addons                     5.7 M
 redhat-upgrade-tool                             noarch              1:0.8.0-4.0.1.el6                   public_ol6_latest              226 k
Installing for dependencies:
 fakeroot                                        x86_64              1.12.2-22.2.el6                     public_ol6_latest               73 k
 fakeroot-libs                                   x86_64              1.12.2-22.2.el6                     public_ol6_latest               22 k
 mod_wsgi                                        x86_64              3.2-7.el6                           public_ol6_latest               66 k
 openscap-engine-sce                             x86_64              1.2.13-2.0.1.el6                    public_ol6_latest               22 k
 openscap-scanner                                x86_64              1.2.13-2.0.1.el6                    public_ol6_latest               47 k
 openscap-utils                                  x86_64              1.2.13-2.0.1.el6                    public_ol6_latest               24 k
 preupgrade-assistant-el6toel7-data              noarch              0.20190214-1.0.1.el6                ol6_addons                     1.5 M
 pykickstart                                     noarch              1.74.22-1.el6                       public_ol6_latest              313 k
 redhat-rpm-config                               noarch              9.0.3-51.0.1.el6                    public_ol6_latest               60 k
 rpm-build                                       x86_64              4.8.0-59.el6                        public_ol6_latest              131 k
 rpmdevtools                                     noarch              7.5-2.0.1.el6                       public_ol6_latest              108 k

Transaction Summary
==============================================================================================================================================
Install      16 Package(s)

Total download size: 9.0 M
Installed size: 33 M
Is this ok [y/N]: y
Downloading Packages:
(1/16): fakeroot-1.12.2-22.2.el6.x86_64.rpm                                                                            |  73 kB     00:00
(2/16): fakeroot-libs-1.12.2-22.2.el6.x86_64.rpm                                                                       |  22 kB     00:00
(3/16): mod_wsgi-3.2-7.el6.x86_64.rpm                                                                                  |  66 kB     00:00
(4/16): openscap-engine-sce-1.2.13-2.0.1.el6.x86_64.rpm                                                                |  22 kB     00:00
(5/16): openscap-scanner-1.2.13-2.0.1.el6.x86_64.rpm                                                                   |  47 kB     00:00
(6/16): openscap-utils-1.2.13-2.0.1.el6.x86_64.rpm                                                                     |  24 kB     00:00
(7/16): preupgrade-assistant-2.6.0-1.0.1.el6.noarch.rpm                                                                | 227 kB     00:00
(8/16): preupgrade-assistant-el6toel7-0.7.9-3.0.1.el6.noarch.rpm                                                       | 396 kB     00:00
(9/16): preupgrade-assistant-el6toel7-data-0.20190214-1.0.1.el6.noarch.rpm                                             | 1.5 MB     00:00
(10/16): preupgrade-assistant-tools-2.6.0-1.0.1.el6.noarch.rpm                                                         |  54 kB     00:00
(11/16): preupgrade-assistant-ui-2.6.0-1.0.1.el6.noarch.rpm                                                            | 5.7 MB     00:01
(12/16): pykickstart-1.74.22-1.el6.noarch.rpm                                                                          | 313 kB     00:00
(13/16): redhat-rpm-config-9.0.3-51.0.1.el6.noarch.rpm                                                                 |  60 kB     00:00
(14/16): redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch.rpm                                                                | 226 kB     00:00
(15/16): rpm-build-4.8.0-59.el6.x86_64.rpm                                                                             | 131 kB     00:00
(16/16): rpmdevtools-7.5-2.0.1.el6.noarch.rpm                                                                          | 108 kB     00:00
----------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                         400 kB/s | 9.0 MB     00:22
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : mod_wsgi-3.2-7.el6.x86_64                                                                                                 1/16
  Installing : pykickstart-1.74.22-1.el6.noarch                                                                                          2/16
  Installing : openscap-scanner-1.2.13-2.0.1.el6.x86_64                                                                                  3/16
  Installing : openscap-engine-sce-1.2.13-2.0.1.el6.x86_64                                                                               4/16
  Installing : fakeroot-libs-1.12.2-22.2.el6.x86_64                                                                                      5/16
  Installing : fakeroot-1.12.2-22.2.el6.x86_64                                                                                           6/16
  Installing : redhat-rpm-config-9.0.3-51.0.1.el6.noarch                                                                                 7/16
  Installing : rpm-build-4.8.0-59.el6.x86_64                                                                                             8/16
  Installing : rpmdevtools-7.5-2.0.1.el6.noarch                                                                                          9/16
  Installing : openscap-utils-1.2.13-2.0.1.el6.x86_64                                                                                   10/16
  Installing : preupgrade-assistant-2.6.0-1.0.1.el6.noarch                                                                              11/16
  Installing : preupgrade-assistant-el6toel7-data-0.20190214-1.0.1.el6.noarch                                                           12/16
  Installing : preupgrade-assistant-el6toel7-0.7.9-3.0.1.el6.noarch                                                                     13/16
  Installing : preupgrade-assistant-ui-2.6.0-1.0.1.el6.noarch                                                                           14/16
  Installing : preupgrade-assistant-tools-2.6.0-1.0.1.el6.noarch                                                                        15/16
  Installing : 1:redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch                                                                             16/16
  Verifying  : preupgrade-assistant-ui-2.6.0-1.0.1.el6.noarch                                                                            1/16
  Verifying  : fakeroot-1.12.2-22.2.el6.x86_64                                                                                           2/16
  Verifying  : preupgrade-assistant-el6toel7-data-0.20190214-1.0.1.el6.noarch                                                            3/16
  Verifying  : preupgrade-assistant-tools-2.6.0-1.0.1.el6.noarch                                                                         4/16
  Verifying  : redhat-rpm-config-9.0.3-51.0.1.el6.noarch                                                                                 5/16
  Verifying  : fakeroot-libs-1.12.2-22.2.el6.x86_64                                                                                      6/16
  Verifying  : preupgrade-assistant-2.6.0-1.0.1.el6.noarch                                                                               7/16
  Verifying  : rpmdevtools-7.5-2.0.1.el6.noarch                                                                                          8/16
  Verifying  : openscap-engine-sce-1.2.13-2.0.1.el6.x86_64                                                                               9/16
  Verifying  : openscap-scanner-1.2.13-2.0.1.el6.x86_64                                                                                 10/16
  Verifying  : preupgrade-assistant-el6toel7-0.7.9-3.0.1.el6.noarch                                                                     11/16
  Verifying  : openscap-utils-1.2.13-2.0.1.el6.x86_64                                                                                   12/16
  Verifying  : 1:redhat-upgrade-tool-0.8.0-4.0.1.el6.noarch                                                                             13/16
  Verifying  : rpm-build-4.8.0-59.el6.x86_64                                                                                            14/16
  Verifying  : pykickstart-1.74.22-1.el6.noarch                                                                                         15/16
  Verifying  : mod_wsgi-3.2-7.el6.x86_64                                                                                                16/16

Installed:
  preupgrade-assistant.noarch 0:2.6.0-1.0.1.el6                        preupgrade-assistant-el6toel7.noarch 0:0.7.9-3.0.1.el6
  preupgrade-assistant-tools.noarch 0:2.6.0-1.0.1.el6                  preupgrade-assistant-ui.noarch 0:2.6.0-1.0.1.el6
  redhat-upgrade-tool.noarch 1:0.8.0-4.0.1.el6

Dependency Installed:
  fakeroot.x86_64 0:1.12.2-22.2.el6                                               fakeroot-libs.x86_64 0:1.12.2-22.2.el6
  mod_wsgi.x86_64 0:3.2-7.el6                                                     openscap-engine-sce.x86_64 0:1.2.13-2.0.1.el6
  openscap-scanner.x86_64 0:1.2.13-2.0.1.el6                                      openscap-utils.x86_64 0:1.2.13-2.0.1.el6
  preupgrade-assistant-el6toel7-data.noarch 0:0.20190214-1.0.1.el6                pykickstart.noarch 0:1.74.22-1.el6
  redhat-rpm-config.noarch 0:9.0.3-51.0.1.el6                                     rpm-build.x86_64 0:4.8.0-59.el6
  rpmdevtools.noarch 0:7.5-2.0.1.el6

Complete!

Run the upgrade assessment command/tools:

[root@proddb ~]# preupg
The Preupgrade Assistant is a diagnostics tool
and does not perform the actual upgrade.
Do you want to continue? [Y/n]
y
Gathering logs used by the Preupgrade Assistant:
All installed packages                                 : 01/10 ...finished (time 00:00s)
All changed files                                      : 02/10 ...finished (time 01:53s)
Changed config files                                   : 03/10 ...finished (time 00:00s)
All users                                              : 04/10 ...finished (time 00:00s)
All groups                                             : 05/10 ...finished (time 00:00s)
Service statuses                                       : 06/10 ...finished (time 00:00s)
All installed files                                    : 07/10 ...finished (time 00:01s)
All local files                                        : 08/10 ...finished (time 00:03s)
All executable files                                   : 09/10 ...finished (time 00:01s)
Oracle signed packages                                 : 10/10 ...finished (time 00:00s)
Assessment of the system, running checks / SCE scripts:
001/141 ...done    (Configuration files to be reviewed) (time: 00:01s)
002/141 ...done    (File lists for the manual migration) (time: 00:00s)
003/141 ...done    (Bacula Backup Software) (time: 00:00s)
004/141 ...done    (MySQL configuration) (time: 00:00s)
005/141 ...done    (MySQL data stack) (time: 00:00s)
006/141 ...done    (Changes related to moving from MySQL to MariaDB) (time: 00:00s)
007/141 ...done    (PostgreSQL) (time: 00:00s)
008/141 ...done    (GNOME desktop environment) (time: 00:00s)
009/141 ...done    (KDE desktop environment) (time: 00:00s)
010/141 ...done    (POWER6 processors) (time: 00:00s)
011/141 ...done    (Graphic drivers not supported in Oracle Linux 7) (time: 00:00s)
012/141 ...done    (Input drivers not supported in Oracle Linux 7) (time: 00:00s)
013/141 ...done    (Kernel networking drivers not available in Oracle Linux 7) (time: 00:00s)
014/141 ...done    (Kernel storage drivers not available in Oracle Linux 7) (time: 00:00s)
015/141 ...done    (Oracle Directory Server) (time: 00:00s)
016/141 ...done    (Arptables) (time: 00:00s)
017/141 ...done    (BIND9 in a chroot environment) (time: 00:00s)
018/141 ...done    (BIND9 configuration compatibility) (time: 00:00s)
019/141 ...done    (Moving the 'dhcpd' and 'dhcrelay' arguments) (time: 00:00s)
020/141 ...done    (Dnsmasq) (time: 00:00s)
021/141 ...done    (Dovecot) (time: 00:00s)
022/141 ...done    (Compatibility between iptables and ip6tables) (time: 00:00s)
023/141 ...done    (Net-SNMP) (time: 00:00s)
024/141 ...done    (NFSv2) (time: 00:00s)
025/141 ...done    (OpenLDAP server daemon configuration) (time: 00:00s)
026/141 ...done    (Moving openssh-keycat) (time: 00:00s)
027/141 ...done    (SSH configuration file and SSH keys) (time: 00:00s)
028/141 ...done    (Postfix) (time: 00:00s)
029/141 ...done    (SMB) (time: 00:00s)
030/141 ...done    (Sendmail) (time: 00:00s)
031/141 ...done    (Squid) (time: 00:00s)
032/141 ...done    (VSFTP daemon configuration) (time: 00:00s)
033/141 ...done    (Reusable configuration files) (time: 00:00s)
034/141 ...done    (Changed configuration files) (time: 00:00s)
035/141 ...done    (Rsyslog configuration incompatibility) (time: 00:00s)
036/141 ...done    (VCS repositories) (time: 00:00s)
037/141 ...done    (Added and extended options for BIND9) (time: 00:00s)
038/141 ...done    (Added options in dnsmasq) (time: 00:00s)
039/141 ...done    (Changes in utilities) (time: 00:00s)
040/141 ...done    (Packages from other system variants) (time: 00:02s)
041/141 ...done    (Load balancer support) (time: 00:02s)
042/141 ...done    (Packages not signed by Oracle) (time: 00:02s)
043/141 ...done    (Obsolete RPM packages) (time: 00:02s)
044/141 ...done    (w3m browser) (time: 00:00s)
045/141 ...done    (The qemu-guest-agent package) (time: 00:00s)
046/141 ...done    (The coreutils packages) (time: 00:00s)
047/141 ...done    (The gawk package) (time: 00:00s)
048/141 ...done    (Removed command line options) (time: 00:00s)
049/141 ...done    (The netstat binary) (time: 00:00s)
050/141 ...done    (Quota) (time: 00:00s)
051/141 ...done    (The util-linux (util-linux-ng) binaries) (time: 00:00s)
052/141 ...done    (Removed RPM packages) (time: 00:05s)
053/141 ...done    (TaskJuggler) (time: 00:00s)
054/141 ...done    (Replaced RPM packages) (time: 00:09s)
055/141 ...done    (GMP library incompatibilities) (time: 00:00s)
056/141 ...done    ("not-base" channels) (time: 00:05s)
057/141 ...done    (Package downgrades) (time: 00:02s)
058/141 ...done    (Custom SELinux policy) (time: 00:00s)
059/141 ...done    (Custom SELinux configuration) (time: 00:00s)
060/141 ...done    (Samba SELinux context check) (time: 00:00s)
061/141 ...done    (Removing sandbox from SELinux) (time: 00:00s)
062/141 ...done    (CUPS Browsing and BrowsePoll) (time: 00:00s)
063/141 ...done    (CVS) (time: 00:00s)
064/141 ...done    (FreeRADIUS) (time: 00:00s)
065/141 ...done    (httpd) (time: 00:00s)
066/141 ...done    (The bind-dyndb-ldap configuration file) (time: 00:00s)
067/141 ...done    (Identity Management Server) (time: 00:00s)
068/141 ...done    (IPA Server CA) (time: 00:00s)
069/141 ...done    (Network Time Protocol) (time: 00:00s)
070/141 ...done    (time-sync.target) (time: 00:00s)
071/141 ...done    (OpenLDAP /etc/sysconfig and data compatibility) (time: 00:00s)
072/141 ...done    (The OpenSSH sshd_config file migration) (time: 00:00s)
073/141 ...done    (The OpenSSH sysconfig/sshd file migration) (time: 00:00s)
074/141 ...done    (The quota_nld service) (time: 00:00s)
075/141 ...done    (Moving the disk quota netlink message daemon into the quota-nld package) (time: 00:00s)
076/141 ...done    (System Security Services Daemon) (time: 00:00s)
077/141 ...done    (Tomcat configuration compatibility check) (time: 00:00s)
078/141 ...done    (Detection of LUKS devices using Whirlpool for password hash) (time: 00:00s)
079/141 ...done    (Detection of Direct Access Storage Device (DASD) format on s390x platform for LDL format) (time: 00:00s)
080/141 ...done    (The clvmd and cmirrord daemon management) (time: 00:00s)
081/141 ...done    (Logical Volume Management 2 services) (time: 00:00s)
082/141 ...done    (Device Mapper Multipath) (time: 00:00s)
083/141 ...done    (The scsi-target-utils packages) (time: 00:00s)
084/141 ...done    (Backing up warnquota) (time: 00:00s)
085/141 ...done    (The warnquota tool) (time: 00:00s)
086/141 ...done    (Add-Ons) (time: 00:00s)
087/141 ...done    (Unsupported architectures) (time: 00:00s)
088/141 ...done    (Binaries to be rebuilt) (time: 01:19s)
089/141 ...done    (Debuginfo packages) (time: 00:02s)
090/141 ...done    (Read-only FHS directories) (time: 00:00s)
091/141 ...done    (FHS incompatibilities) (time: 00:00s)
092/141 ...done    (Requirements for the /usr/ directory) (time: 00:00s)
093/141 ...done    (Cluster and High Availability) (time: 00:00s)
094/141 ...done    (The quorum implementation) (time: 00:00s)
095/141 ...done    (The krb5kdc configuration file) (time: 00:00s)
096/141 ...done    (File systems, partitions, and the mounts configuration) (time: 00:00s)
097/141 ...done    (Removable media in the /etc/fstab file) (time: 00:00s)
098/141 ...done    (Libraries with their soname bumped) (time: 00:06s)
099/141 ...done    (Libraries with their soname kept) (time: 00:07s)
100/141 ...done    (Removed .so libraries) (time: 01:30s)
101/141 ...done    (CGROUP_DAEMON in sysconfig scripts) (time: 00:00s)
102/141 ...done    (Checking the system version and variant) (time: 00:00s)
103/141 ...done    (Consequences of upgrading to RHEL 7.6 instead of the latest RHEL minor version) (time: 00:00s)
104/141 ...done    (AIDE) (time: 00:00s)
105/141 ...done    (CA bundles) (time: 00:00s)
106/141 ...done    (Oracle Developer Toolset) (time: 00:00s)
107/141 ...done    (GRUB to GRUB 2 migration) (time: 00:00s)
108/141 ...done    (Grubby) (time: 00:00s)
109/141 ...done    (Obsoleting Hardware Abstraction Layer) (time: 00:10s)
110/141 ...done    (Hyper-V) (time: 00:00s)
111/141 ...done    (Enabled and disabled services in Oracle Linux 6) (time: 00:03s)
112/141 ...done    (Ethernet interface naming) (time: 00:00s)
113/141 ...done    (The /etc/rc.local and /etc/rc.d/rc.local files) (time: 00:00s)
114/141 ...done    (java-1.8.0-ibm compatibility check) (time: 00:00s)
115/141 ...done    (Java upgrade) (time: 00:00s)
116/141 ...done    (The kernel-kdump package) (time: 00:00s)
117/141 ...done    (The cgroups configuration compatibility) (time: 00:00s)
118/141 ...done    (Pluggable authentication modules (PAM)) (time: 00:00s)
119/141 ...done    (Perl modules not distributed by Oracle) (time: 00:21s)
120/141 ...done    (PHP modules not distributed by Oracle) (time: 00:00s)
121/141 ...done    (PolicyKit) (time: 00:00s)
122/141 ...done    (Python packages) (time: 00:03s)
123/141 ...done    (Repositories for Kickstart) (time: 00:00s)
124/141 ...done    (System requirements) (time: 00:00s)
125/141 ...done    (Ruby 2.0.0) (time: 00:00s)
126/141 ...done    (Oracle Software Collections (RHSCL)) (time: 00:00s)
127/141 ...done    (Oracle Subscription Manager) (time: 00:00s)
128/141 ...done    (Oracle Network Classic unsupported) (time: 00:00s)
129/141 ...done    (Copying Kickstart) (time: 00:00s)
130/141 ...done    (The 'tuned' profiles) (time: 00:00s)
131/141 ...done    (UEFI boot loader) (time: 00:00s)
132/141 ...done    (Yaboot) (time: 00:00s)
133/141 ...done    (The yum configuration file) (time: 00:06s)
134/141 ...done    (Dangerous ranges of UIDs and GIDs) (time: 00:00s)
135/141 ...done    (Incorrect usage of reserved UIDs and GIDs) (time: 00:01s)
136/141 ...done    (The libuser.conf file) (time: 00:00s)
137/141 ...done    (NIS ypbind) (time: 00:00s)
138/141 ...done    (NIS Makefile) (time: 00:00s)
139/141 ...done    (NIS server maps) (time: 00:00s)
140/141 ...done    (NIS server UID_MIN and GID_MIN limits) (time: 00:00s)
141/141 ...done    (The NIS server configuration file) (time: 00:00s)
The assessment finished (time 04:34s)
The '/root/preupgrade/dirtyconf/etc/sysconfig/rhn/up2date' file already exists in the dirtyconf directory
Result table with checks and their results for 'main contents':
-------------------------------------------------------------------------------------------------------------------
|Bacula Backup Software                                                                        |notapplicable     |
|PostgreSQL                                                                                    |notapplicable     |
|Oracle Directory Server                                                                       |notapplicable     |
|Arptables                                                                                     |notapplicable     |
|BIND9 in a chroot environment                                                                 |notapplicable     |
|BIND9 configuration compatibility                                                             |notapplicable     |
|Moving the 'dhcpd' and 'dhcrelay' arguments                                                   |notapplicable     |
|Dovecot                                                                                       |notapplicable     |
|Net-SNMP                                                                                      |notapplicable     |
|OpenLDAP server daemon configuration                                                          |notapplicable     |
|SMB                                                                                           |notapplicable     |
|Sendmail                                                                                      |notapplicable     |
|Squid                                                                                         |notapplicable     |
|VSFTP daemon configuration                                                                    |notapplicable     |
|Added and extended options for BIND9                                                          |notapplicable     |
|Load balancer support                                                                         |notapplicable     |
|w3m browser                                                                                   |notapplicable     |
|The qemu-guest-agent package                                                                  |notapplicable     |
|TaskJuggler                                                                                   |notapplicable     |
|Custom SELinux configuration                                                                  |notapplicable     |
|Samba SELinux context check                                                                   |notapplicable     |
|FreeRADIUS                                                                                    |notapplicable     |
|The bind-dyndb-ldap configuration file                                                        |notapplicable     |
|Identity Management Server                                                                    |notapplicable     |
|IPA Server CA                                                                                 |notapplicable     |
|OpenLDAP /etc/sysconfig and data compatibility                                                |notapplicable     |
|System Security Services Daemon                                                               |notapplicable     |
|Tomcat configuration compatibility check                                                      |notapplicable     |
|Detection of Direct Access Storage Device (DASD) format on s390x platform for LDL format      |notapplicable     |
|The clvmd and cmirrord daemon management                                                      |notapplicable     |
|Device Mapper Multipath                                                                       |notapplicable     |
|The scsi-target-utils packages                                                                |notapplicable     |
|The quorum implementation                                                                     |notapplicable     |
|The krb5kdc configuration file                                                                |notapplicable     |
|AIDE                                                                                          |notapplicable     |
|java-1.8.0-ibm compatibility check                                                            |notapplicable     |
|The kernel-kdump package                                                                      |notapplicable     |
|PHP modules not distributed by Oracle                                                         |notapplicable     |
|Ruby 2.0.0                                                                                    |notapplicable     |
|Oracle Network Classic unsupported                                                            |notapplicable     |
|Oracle Subscription Manager                                                                   |notapplicable     |
|The 'tuned' profiles                                                                          |notapplicable     |
|Yaboot                                                                                        |notapplicable     |
|NIS ypbind                                                                                    |notapplicable     |
|NIS Makefile                                                                                  |notapplicable     |
|NIS server maps                                                                               |notapplicable     |
|NIS server UID_MIN and GID_MIN limits                                                         |notapplicable     |
|The NIS server configuration file                                                             |notapplicable     |
|MySQL data stack                                                                              |pass              |
|POWER6 processors                                                                             |pass              |
|Graphic drivers not supported in Oracle Linux 7                                               |pass              |
|Input drivers not supported in Oracle Linux 7                                                 |pass              |
|Kernel networking drivers not available in Oracle Linux 7                                     |pass              |
|Kernel storage drivers not available in Oracle Linux 7                                        |pass              |
|Dnsmasq                                                                                       |pass              |
|Reusable configuration files                                                                  |pass              |
|time-sync.target                                                                              |pass              |
|The OpenSSH sshd_config file migration                                                        |pass              |
|The quota_nld service                                                                         |pass              |
|Moving the disk quota netlink message daemon into the quota-nld package                       |pass              |
|Detection of LUKS devices using Whirlpool for password hash                                   |pass              |
|Backing up warnquota                                                                          |pass              |
|Add-Ons                                                                                       |pass              |
|Unsupported architectures                                                                     |pass              |
|Debuginfo packages                                                                            |pass              |
|Read-only FHS directories                                                                     |pass              |
|Requirements for the /usr/ directory                                                          |pass              |
|Cluster and High Availability                                                                 |pass              |
|CGROUP_DAEMON in sysconfig scripts                                                            |pass              |
|Checking the system version and variant                                                       |pass              |
|CA bundles                                                                                    |pass              |
|Oracle Developer Toolset                                                                      |pass              |
|Obsoleting Hardware Abstraction Layer                                                         |pass              |
|Hyper-V                                                                                       |pass              |
|The /etc/rc.local and /etc/rc.d/rc.local files                                                |pass              |
|Pluggable authentication modules (PAM)                                                        |pass              |
|System requirements                                                                           |pass              |
|Oracle Software Collections (RHSCL)                                                           |pass              |
|Copying Kickstart                                                                             |pass              |
|Dangerous ranges of UIDs and GIDs                                                             |pass              |
|The libuser.conf file                                                                         |pass              |
|MySQL configuration                                                                           |informational     |
|Changes related to moving from MySQL to MariaDB                                               |informational     |
|NFSv2                                                                                         |informational     |
|Postfix                                                                                       |informational     |
|Rsyslog configuration incompatibility                                                         |informational     |
|VCS repositories                                                                              |informational     |
|Added options in dnsmasq                                                                      |informational     |
|The coreutils packages                                                                        |informational     |
|The gawk package                                                                              |informational     |
|Removed command line options                                                                  |informational     |
|The netstat binary                                                                            |informational     |
|Quota                                                                                         |informational     |
|The util-linux (util-linux-ng) binaries                                                       |informational     |
|GMP library incompatibilities                                                                 |informational     |
|CVS                                                                                           |informational     |
|Network Time Protocol                                                                         |informational     |
|The warnquota tool                                                                            |informational     |
|FHS incompatibilities                                                                         |informational     |
|File systems, partitions, and the mounts configuration                                        |informational     |
|Removable media in the /etc/fstab file                                                        |informational     |
|Libraries with their soname kept                                                              |informational     |
|Consequences of upgrading to RHEL 7.6 instead of the latest RHEL minor version                |informational     |
|Perl modules not distributed by Oracle                                                        |informational     |
|PolicyKit                                                                                     |informational     |
|UEFI boot loader                                                                              |informational     |
|The yum configuration file                                                                    |informational     |
|SSH configuration file and SSH keys                                                           |fixed             |
|Package downgrades                                                                            |fixed             |
|Custom SELinux policy                                                                         |fixed             |
|CUPS Browsing and BrowsePoll                                                                  |fixed             |
|The OpenSSH sysconfig/sshd file migration                                                     |fixed             |
|Logical Volume Management 2 services                                                          |fixed             |
|Grubby                                                                                        |fixed             |
|File lists for the manual migration                                                           |needs_inspection  |
|Compatibility between iptables and ip6tables                                                  |needs_inspection  |
|Moving openssh-keycat                                                                         |needs_inspection  |
|Changed configuration files                                                                   |needs_inspection  |
|Changes in utilities                                                                          |needs_inspection  |
|Obsolete RPM packages                                                                         |needs_inspection  |
|httpd                                                                                         |needs_inspection  |
|Binaries to be rebuilt                                                                        |needs_inspection  |
|Libraries with their soname bumped                                                            |needs_inspection  |
|Removed .so libraries                                                                         |needs_inspection  |
|Python packages                                                                               |needs_inspection  |
|Repositories for Kickstart                                                                    |needs_inspection  |
|Incorrect usage of reserved UIDs and GIDs                                                     |needs_inspection  |
|Configuration files to be reviewed                                                            |needs_action      |
|Packages from other system variants                                                           |needs_action      |
|Packages not signed by Oracle                                                                 |needs_action      |
|Removed RPM packages                                                                          |needs_action      |
|Replaced RPM packages                                                                         |needs_action      |
|"not-base" channels                                                                           |needs_action      |
|Removing sandbox from SELinux                                                                 |needs_action      |
|GRUB to GRUB 2 migration                                                                      |needs_action      |
|Enabled and disabled services in Oracle Linux 6                                               |needs_action      |
|Ethernet interface naming                                                                     |needs_action      |
|Java upgrade                                                                                  |needs_action      |
|The cgroups configuration compatibility                                                       |needs_action      |
|GNOME desktop environment                                                                     |fail              |
|KDE desktop environment                                                                       |fail              |
-------------------------------------------------------------------------------------------------------------------
The tarball with results is stored in '/root/preupgrade-results/preupg_results-201002120101.tar.gz' .
The latest assessment is stored in the '/root/preupgrade' directory.
Summary information:
We have found some critical issues. In-place upgrade or migration is not advised.
Read the file /root/preupgrade/result.html for more details.
Please ensure you have backed up your system and/or data
before doing a system upgrade to prevent loss of data in
case the upgrade fails and full re-install of the system
from installation media is needed.
Upload results to UI by the command:
e.g. preupg -u http://example.com:8099/submit/ -r /root/preupgrade-results/preupg_results-201002120101.tar.gz .

Copy the ISO to the server:

[oracle@proddb backup]$ pwd
/u01/backup
[oracle@proddb backup]$ ls -lrt
total 4464644
-rw-r--r--. 1 root root 4571791360 Oct  2 13:46 V980739-01.iso

Run the upgrade tool:

[root@proddb dev]# redhat-upgrade-tool-cli --iso=/u01/backup/V74844-01.iso --debuglog=/tmp/upgrade.log --cleanup-post
setting up repos...
upgradeiso                                                                                                             | 3.6 kB     00:00 ...
upgradeiso/primary_db                                                                                                  | 4.0 MB     00:00 ...
The installed version of Preupgrade Assistant allows upgrade only to the system version 7.6.

Above ISO version is 7.1 but Installed version of Preupgrade Assistant 7.6

As failed few components, It was not allowing to upgrade. Then run with force command.

Note::: But for Prod environment, its not recommended to run with force but resolved all issues before running final upgradation command.

[root@proddb ~]# redhat-upgrade-tool-cli --iso=/u01/backup/V980739-01.iso --debuglog=/tmp/upgrade.log --cleanup-post
setting up repos...
upgradeiso                                                                                                             | 3.6 kB     00:00 ...
upgradeiso/primary_db                                                                                                  | 5.0 MB     00:00 ...
The Preupgrade Assistant has found EXTREME upgrade risks.
Run preupg --riskcheck --verbose to view
 these risks.
Continuing with this upgrade is not
 recommended - the system will be unsupported
 and most likely broken after the upgrade.
[root@proddb ~]# redhat-upgrade-tool-cli --iso=/u01/backup/V980739-01.iso --debuglog=/tmp/upgrade.log --cleanup-post --force
setting up repos...
upgradeiso                                                                                                             | 3.6 kB     00:00 ...
upgradeiso/primary_db                                                                                                  | 5.0 MB     00:00 ...
getting boot images...
vmlinuz-redhat-upgrade-tool                                                                                            | 6.3 MB     00:00 ...
initramfs-redhat-upgrade-tool.img                                                                                      |  58 MB     00:00 ...
setting up update...
upgradeiso/filelists_db                                                                                                | 3.8 MB     00:00 ...
finding updates 100% [=============================================================================================================================]testing upgrade transaction
rpm transaction 100% [=============================================================================================================================]
rpm install 100% [=================================================================================================================================]
setting up system for upgrade
HOOK-pkgdowngrades: INFO: start with arguments: /root/preupgrade/pkgdowngrades/enforce_downgraded --destdir=/root/preupgrade/pkgdowngrades/rpms --installroot=/root/preupgrade/pkgdowngrades/installroot --rhelupdir=/var/lib/system-upgrade
Loaded plugins: refresh-packagekit
No plugin match for: rhnplugin
Repository 'public_ol6_UEK_latest': Error parsing config: Error parsing "enabled = '$uek'": invalid boolean value
Repository 'public_ol6_UEKR3_latest': Error parsing config: Error parsing "enabled = '$uekr3'": invalid boolean value
Repository 'public_ol6_UEKR4': Error parsing config: Error parsing "enabled = '$uekr4'": invalid boolean value
Loaded plugins: refresh-packagekit
HOOK-pkgdowngrades: WARNING: The ncurses-base.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'kde-filesystem' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The system-config-keyboard-base.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The system-config-keyboard.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The kdegraphics-libs.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The kdeaccessibility.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Pod-Escapes.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Pod-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Pluggable.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Locale-Maketext-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Params-Check.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Load.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Load-Conditional.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Log-Message.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Package-Constants.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-IO-Zlib.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Archive-Tar.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Log-Message-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Term-UI.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Object-Accessor.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-CoreList.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Loaded.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Parse-CPAN-Meta.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-parent.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-CGI.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'hwdata' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'rhn-client-tools' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-ParseXS.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Test-Harness.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-MakeMaker.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-IPC-Cmd.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-File-Fetch.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Archive-Extract.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-CBuilder.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Build.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-CPANPLUS.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-CPAN.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Test-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-Embed.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'dracut' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The samba-common.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'rhn-setup' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'rhn-check' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'rhn-setup-gnome' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'man-pages-overrides' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'plymouth-system-theme' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libgcc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'redhat-release-server.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'fontpackages-filesystem.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'tzdata-java.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dejavu-fonts-common.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'tzdata.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ncurses-base.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'oraclelinux-release.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'setup.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'bash.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'filesystem.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'basesystem.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-softokn-freebl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glibc-common.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glibc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libstdc++.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nspr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ncurses-libs.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-util.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsepol.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pcre.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libselinux.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'zlib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'info.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xz-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'expat.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'bzip2-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libdb.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'sed.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libffi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libuuid.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'popt.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'chkconfig.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libjpeg-turbo.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'grep.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libpng.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'freetype.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'elfutils-libelf.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcom_err.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libattr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libacl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcap.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxml2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libgpg-error.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libgcrypt.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'readline.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'lua.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cpio.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gawk.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'findutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libglapi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libICE.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libogg.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcap-ng.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'audit-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libSM.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'sqlite.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-softokn.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxslt.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libwayland-server.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'p11-kit.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xz.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libidn.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'diffutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libmnl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libnfnetlink.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxshmfence.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'lz4.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libglvnd.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gdbm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libnetfilter_conntrack.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'iptables.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'iproute.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libvorbis.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'flac-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'copy-jdk-configs.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'acl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'tar.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ttmkfdir.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'jasper-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libwayland-client.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'groff-base.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-parent.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-HTTP-Tiny.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-podlators.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Perldoc.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Text-ParseWords.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Encode.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Escapes.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Usage.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-macros.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Socket.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Storable.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Time-HiRes.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-threads.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Scalar-List-Utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-threads-shared.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-constant.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Carp.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Filter.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Exporter.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-File-Temp.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-File-Path.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-PathTools.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Time-Local.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Simple.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Getopt-Long.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libdb-utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kmod-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'which.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libfontenc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'psmisc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ncurses.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mozjs17.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'graphite2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gmp.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'sysvinit-tools.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'fribidi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gpm-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pcsc-lite-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsmartcols.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXau.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxcb.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ustr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsemanage.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libverto.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gsm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsndfile.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pixman.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'tcp_wrappers-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'qrencode-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hostname.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'keyutils-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libtasn1.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'p11-kit-trust.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'ca-certificates.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'coreutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'openssl-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'krb5-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'shadow-utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libblkid.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libmount.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glib2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'shared-mime-info.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gzip.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cracklib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cracklib-dicts.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pam.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libpwquality.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pkgconfig.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'atk.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'alsa-lib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python-lxml.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python-javapackages.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'javapackages-tools.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xorg-x11-font-utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'harfbuzz.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'grubby.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libutempter.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cyrus-sasl-lib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libssh2.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-sysinit.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'nss-pem.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-tools.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcurl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'curl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'rpm-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'rpm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'openldap.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libuser.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hicolor-icon-theme.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'linux-firmware.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'binutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hardlink.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libasyncns.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libthai.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'json-c.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kpartx.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'device-mapper.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'util-linux.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'procps-ng.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'device-mapper-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cryptsetup-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dracut.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kmod.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'elfutils-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'systemd-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dbus-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'systemd.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dbus.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'elfutils-default-yama-scope.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'polkit.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'polkit-pkla-compat.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hwdata.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libpciaccess.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libdrm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libgbm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'iputils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'initscripts.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kernel.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'avahi-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cups-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dbus-glib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'GConf2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'jbigkit-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libtiff.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dejavu-sans-fonts.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'fontconfig.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xorg-x11-fonts-Type1.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mailcap.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-filesystem.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-common.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libX11-common.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libX11.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXext.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXrender.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXfixes.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXtst.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXcomposite.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gdk-pixbuf2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pulseaudio-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXdamage.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'giflib.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'java-1.6.0-openjdk.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'java-1.7.0-openjdk-headless.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gtk-update-icon-cache.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXcursor.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXrandr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXft.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXxf86vm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libglvnd-glx.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libGL.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXinerama.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libglvnd-egl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libEGL.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cairo.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pango.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gtk2.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'java-1.7.0-openjdk.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'mesa-libGLU.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'glx-utils.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-enhanced.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'microcode_ctl.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'satyr.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'xcb-util.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-minimal.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'libvpx.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'redhat-menus.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-softokn-freebl.i686'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glibc.i686'
HOOK-pkgdowngrades: INFO: done
Shutting down interface eth0:  Device state: 3 (disconnected)
                                                           [  OK  ]
Shutting down interface eth1:  Device state: 3 (disconnected)
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
RTNETLINK answers: Device or resource busy
RTNETLINK answers: Device or resource busy
Bringing up loopback interface:                            [  OK  ]
Bringing up interface net0:  Active connection state: activated
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/2
                                                           [  OK  ]
Bringing up interface net1:  Error: Connection activation failed: The connection is not for this device.
                                                           [FAILED]
Following preupgrade script(s) failed:

/root/preupgrade/preupgrade-scripts/rename_network.sh exited with status 1
exiting

Run the same update tool again as first time got failed:

[root@proddb ~]# redhat-upgrade-tool-cli --iso=/u01/backup/V980739-01.iso --debuglog=/tmp/upgrade.log --cleanup-post --force
setting up repos...
upgradeiso                                                                                                                   | 3.6 kB     00:00 ...
upgradeiso/primary_db                                                                                                        | 5.0 MB     00:00 ...
getting boot images...
initramfs-redhat-upgrade-tool.img                                                                                            |  58 MB     00:00 ...
setting up update...
upgradeiso/filelists_db                                                                                                      | 3.8 MB     00:00 ...
finding updates 100% [=============================================================================================================================]
testing upgrade transaction
rpm transaction 100% [=============================================================================================================================]
rpm install 100% [=================================================================================================================================]
setting up system for upgrade
HOOK-pkgdowngrades: INFO: start with arguments: /root/preupgrade/pkgdowngrades/enforce_downgraded --destdir=/root/preupgrade/pkgdowngrades/rpms --installroot=/root/preupgrade/pkgdowngrades/installroot --rhelupdir=/var/lib/system-upgrade
Loaded plugins: refresh-packagekit
No plugin match for: rhnplugin
Repository 'public_ol6_UEK_latest': Error parsing config: Error parsing "enabled = '$uek'": invalid boolean value
Repository 'public_ol6_UEKR3_latest': Error parsing config: Error parsing "enabled = '$uekr3'": invalid boolean value
Repository 'public_ol6_UEKR4': Error parsing config: Error parsing "enabled = '$uekr4'": invalid boolean value
Loaded plugins: refresh-packagekit
HOOK-pkgdowngrades: WARNING: The ncurses-base.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'kde-filesystem' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The system-config-keyboard-base.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The system-config-keyboard.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The kdegraphics-libs.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The kdeaccessibility.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Pod-Escapes.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Pod-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Pluggable.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Locale-Maketext-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Params-Check.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Load.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Load-Conditional.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Log-Message.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Package-Constants.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-IO-Zlib.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Archive-Tar.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Log-Message-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Term-UI.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Object-Accessor.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-CoreList.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Loaded.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Parse-CPAN-Meta.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-parent.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-CGI.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'hwdata' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'rhn-client-tools' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-ParseXS.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Test-Harness.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-MakeMaker.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-IPC-Cmd.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-File-Fetch.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Archive-Extract.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-CBuilder.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Module-Build.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-CPANPLUS.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-CPAN.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-Test-Simple.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The perl-ExtUtils-Embed.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'dracut' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The samba-common.x86_64 package switched to 'noarch' in the next RHEL release.
HOOK-pkgdowngrades: WARNING: The 'rhn-setup' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'rhn-check' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'rhn-setup-gnome' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'man-pages-overrides' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: WARNING: The 'plymouth-system-theme' package is not noarch anymore, x86_64 will be installed.
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libgcc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'redhat-release-server.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'fontpackages-filesystem.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'tzdata-java.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dejavu-fonts-common.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'tzdata.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ncurses-base.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'oraclelinux-release.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'setup.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'bash.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'filesystem.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'basesystem.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-softokn-freebl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glibc-common.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glibc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libstdc++.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nspr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ncurses-libs.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-util.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsepol.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pcre.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libselinux.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'zlib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'info.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xz-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'expat.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'bzip2-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libdb.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'sed.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libffi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libuuid.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'popt.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'chkconfig.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libjpeg-turbo.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'grep.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libpng.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'freetype.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'elfutils-libelf.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcom_err.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libattr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libacl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcap.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxml2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libgpg-error.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libgcrypt.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'readline.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'lua.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cpio.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gawk.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'findutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libglapi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libICE.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libogg.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcap-ng.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'audit-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libSM.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'sqlite.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-softokn.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxslt.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libwayland-server.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'p11-kit.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xz.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libidn.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'diffutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libmnl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libnfnetlink.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxshmfence.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'lz4.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libglvnd.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gdbm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libnetfilter_conntrack.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'iptables.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'iproute.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libvorbis.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'flac-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'copy-jdk-configs.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'acl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'tar.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ttmkfdir.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'jasper-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libwayland-client.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'groff-base.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-parent.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-HTTP-Tiny.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-podlators.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Perldoc.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Text-ParseWords.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Encode.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Escapes.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Usage.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-macros.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Socket.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Storable.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Time-HiRes.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-threads.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Scalar-List-Utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-threads-shared.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-constant.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Carp.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Filter.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Exporter.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-File-Temp.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-File-Path.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-PathTools.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Time-Local.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Pod-Simple.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl-Getopt-Long.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'perl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libdb-utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kmod-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'which.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libfontenc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'psmisc.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ncurses.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mozjs17.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'graphite2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gmp.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'sysvinit-tools.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'fribidi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gpm-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pcsc-lite-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsmartcols.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXau.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libxcb.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'ustr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsemanage.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libverto.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gsm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libsndfile.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pixman.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'tcp_wrappers-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'qrencode-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hostname.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'keyutils-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libtasn1.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'p11-kit-trust.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'ca-certificates.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'coreutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'openssl-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'krb5-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'shadow-utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libblkid.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libmount.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glib2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'shared-mime-info.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gzip.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cracklib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cracklib-dicts.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pam.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libpwquality.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pkgconfig.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'atk.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'alsa-lib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python-lxml.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'python-javapackages.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'javapackages-tools.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xorg-x11-font-utils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'harfbuzz.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'grubby.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libutempter.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cyrus-sasl-lib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libssh2.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-sysinit.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'nss-pem.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-tools.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libcurl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'curl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'rpm-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'rpm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'openldap.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libuser.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hicolor-icon-theme.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'linux-firmware.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'binutils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hardlink.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libasyncns.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libthai.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'json-c.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kpartx.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'device-mapper.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'util-linux.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'procps-ng.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'device-mapper-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cryptsetup-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dracut.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kmod.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'elfutils-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'systemd-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dbus-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'systemd.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dbus.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'elfutils-default-yama-scope.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'polkit.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'polkit-pkla-compat.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'hwdata.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libpciaccess.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libdrm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libgbm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'iputils.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'initscripts.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'kernel.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'avahi-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cups-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dbus-glib.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'GConf2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'jbigkit-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libtiff.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'dejavu-sans-fonts.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'fontconfig.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'xorg-x11-fonts-Type1.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mailcap.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-filesystem.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-common.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libX11-common.noarch'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libX11.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXext.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXrender.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXi.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXfixes.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXtst.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXcomposite.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gdk-pixbuf2.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pulseaudio-libs.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXdamage.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'giflib.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'java-1.6.0-openjdk.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'java-1.7.0-openjdk-headless.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gtk-update-icon-cache.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXcursor.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXrandr.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXft.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXxf86vm.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libglvnd-glx.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libGL.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libXinerama.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'libglvnd-egl.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'mesa-libEGL.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'cairo.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'pango.x86_64'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'gtk2.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'java-1.7.0-openjdk.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'mesa-libGLU.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'glx-utils.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-enhanced.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'microcode_ctl.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'satyr.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'xcb-util.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'vim-minimal.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'libvpx.x86_64'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'redhat-menus.noarch'
HOOK-pkgdowngrades: INFO: DOWNGRADE: enforcing package installation 'nss-softokn-freebl.i686'
HOOK-pkgdowngrades: INFO: DEP: enforcing package installation 'glibc.i686'
HOOK-pkgdowngrades: INFO: done
Shutting down interface net0:  Device state: 3 (disconnected)
                                                           [  OK  ]
Shutting down interface net1:  Device state: 3 (disconnected)
                                                           [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Cannot find device "eth0"
Cannot find device "eth1"
Bringing up loopback interface:                            [  OK  ]
Bringing up interface net0:  Active connection state: activated
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/3
                                                           [  OK  ]
Bringing up interface net1:  Active connection state: activating
Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/4
state: activated
Connection activated
                                                           [  OK  ]
Finished. Reboot to start upgrade.

Reboot the system to start the upgrade process:

After rebooted the system, it would take sometimes to complete.

Version details after upgradation:

[root@proddb ~]# cat /etc/*-release
LSB_VERSION=core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Oracle Linux Server release 7.6
NAME="Oracle Linux Server"
VERSION="7.6"
ID="ol"
VARIANT="Server"
VARIANT_ID="server"
VERSION_ID="7.6"
PRETTY_NAME="Oracle Linux Server 7.6"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:oracle:linux:7:6:server"
HOME_URL="https://linux.oracle.com/"
BUG_REPORT_URL="https://bugzilla.oracle.com/"

ORACLE_BUGZILLA_PRODUCT="Oracle Linux 7"
ORACLE_BUGZILLA_PRODUCT_VERSION=7.6
ORACLE_SUPPORT_PRODUCT="Oracle Linux"
ORACLE_SUPPORT_PRODUCT_VERSION=7.6
Red Hat Enterprise Linux Server release 7.6 (Maipo)
Oracle Linux Server release 7.6

After upgradation, database Status:

[oracle@proddb ~]$ sqlplus / as sysdba

SQL*Plus: Release 12.1.0.2.0 Production on Fri Oct 2 15:13:38 2020

Copyright (c) 1982, 2014, Oracle.  All rights reserved.

Connected to an idle instance.

SQL> startup
ORACLE instance started.

Total System Global Area 1560281088 bytes
Fixed Size                  2924784 bytes
Variable Size            1006636816 bytes
Database Buffers          536870912 bytes
Redo Buffers               13848576 bytes
Database mounted.
Database opened.

SQL> select * from t1;

        ID NAME
---------- ----------
        10 samad

SQL> conn samad
Enter password:
Connected.

For more option or details, you may check oracle document: OEL In-place upgrade

Leave a Reply